Welcome, Guest. Please login or register.

Author Topic: GUI does not show - diacritical char  (Read 1034 times)

miso

  • Newbie
  • *
  • Posts: 1
  • Karma: +1/-0
    • View Profile
GUI does not show - diacritical char
« on: July 12, 2013, 04:06:42 PM »
Hi!

I have just downloaded 0.3.4 and run it for the first time with double click. No GUI, just two processes in Task manager.
Tried old versions from Archive, but no success. Tried on Windows 8 64 bit and Windows 7 64 bit, both with Windows user with letter "š" (included in ASCII 8bit).
Only keys.dat and knownnodes.dat were created.

I created a new Windows account "test" and it worked! messages.dat was created.

Please, fix this :)

Thank you.

EDIT: quick solution: enable portable mode (move all files from %appdata%\PyBitmessage to folder with Bitmessage.exe)
« Last Edit: July 12, 2013, 05:24:18 PM by miso »

Atheros

  • Lead Bitmessage developer
  • Administrator
  • Sr. Member
  • *****
  • Posts: 381
  • Karma: +57/-3
    • View Profile
Re: GUI does not show - diacritical char
« Reply #1 on: July 13, 2013, 06:50:01 PM »
acknowledged.

MMMark

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: GUI does not show - diacritical char
« Reply #2 on: March 09, 2018, 03:50:13 PM »
Fri. 18/03/09 15:48 EST
post #1

I've been testing Bitmessage for several months and I'd like to share some problems and observations.

I'm using a Windows 7 SP1 x-86 desktop computer and running Bitmessage (currently version 0.6.3.2, SHA-256: E714337AC069B06AA5BA66CC37C55EBF6DA0546838E96850818474544742FE58) from a USB stick.  I also use Process Explorer to see what is running on my computer.  Here is what PyBitmessage support BM-2cUdgkDDAahwPAU6oD2A7DnjqZz3hgY832 (in the Send tab) reports:

PyBitmessage version: 0.6.3.2
Operating system: Windows 6.1
Architecture: 32bit
Python Version: 2.7.14 (v2.7.14:84471935ed, Sep 16 2017, 20:19:30) [MSC v.1500 32 bit (Intel)]
OpenSSL Version: OpenSSL 1.0.2k  26 Jan 2017 (Python internal), OpenSSL 1.0.2n  7 Dec 2017 (external for PyElliptic)
Frozen: True
Portable mode: True
C PoW: True
OpenCL PoW: None
Locale: en_CA
SOCKS: none
UPnP: N/A
Connected hosts: 9

At some point, when I'd start Bitmessage it would no longer display its Graphical User Interface (GUI) although Process Explorer would show that it was running.  I first removed a file named messages.dat-journal, after which Bitmessage would start and display its GUI, but would then terminate.  I found the following message in debug.log:

|2018-03-06 15:19:04,046 - CRITICAL - Major error occurred when trying to execute a SQL statement within the sqlThread. Please tell Atheros about this error message or post it in the forum! Error occurred while trying to execute statement: "SELECT hash FROM inventory WHERE streamnumber=? AND expirestime>?"  Here are the parameters; you might want to censor this data with asterisks (***) as it can contain private information: (1, 1520367544). Here is the actual error message thrown by the sqlThread: database disk image is malformed

2018-03-06 15:19:04,046 - CRITICAL - This program shall now abruptly exit!|


My next step was to remove both messages.dat-journal and messages.dat.  Now Bitmessage started and behaved correctly.  Furthermore, it would, upon startup, briefly generate a file named messages.dat-journal, which would then disappear.

What I then noticed was that I could shut down and then restart Bitmessage, and it would function correctly.  However, after shutting down and restarting the computer, I'd have to once again remove both messages.dat-journal and messages.dat before Bitmessage would display its GUI...but today, Bitmessage starts and functions correctly.

Update:  Bitmessage is now "not responding" and I see that the file messages.dat-journal once again appears.  Next, Bitmessage begins to function normally and messages.dat-journal disappears.

What follows are the debug.log lines that pertain to my most recent startup of Bitmessage; I believe these lines appear after every successful startup of Bitmessage:

2018-03-09 12:03:05,240 - ERROR - C PoW test fail.
Traceback (most recent call last):
  File "proofofwork.py", line 256, in init
  File "proofofwork.py", line 106, in _doCPoW
ValueError: Procedure probably called with too many arguments (12 bytes in excess)
2018-03-09 12:03:11,084 - WARNING - No indicator plugin found
2018-03-09 12:03:11,088 - WARNING - No notification.message plugin found


Current size of messages.dat: 73,502,720 bytes.

Next step: Read the "Critical vulnerability in v0.6.1" message:

Now, size of messages.dat: 73,531,392 bytes.

Shut down and restart Bitmessage: It restarts and functions normally.
Shut down again (connection status is yellow): Bitmessage stops responding.  Eventually I use Process Explorer to kill the process.
Shut down and restart computer: Bitmessage starts and functions normally, although it once again freezes ("not responding") upon shutdown.

Other observations:
- I once observed (upon start up, I believe) the brief appearance of a file named messages.dat.bak.
- Despite the fact that only one message (Critical vulnerability in v0.6.1) appears in any of Bitmessage's Message folders, messages.dat is 73,531,392 bytes in size.  After deleting the "Critical vulnerability in v0.6.1" message, the size of messages.dat remains unchanged at 73,531,392 bytes.
- right-clicking on the Bitmessage icon in the System Tray produces a small menu, one item of which is Quiet Mode.  I do not find any documentation for this feature; can anyone explain it?
« Last Edit: March 09, 2018, 04:26:33 PM by MMMark »

Peter Šurda

  • Full Member
  • ***
  • Posts: 137
  • Karma: +4/-0
    • View Profile
Re: GUI does not show - diacritical char
« Reply #3 on: April 03, 2018, 01:42:42 AM »
Your USB stick could be corrupt, or you could be unplugging it prematurely.